Home News Reviews Forums Shop


Server Migration and Forum Bugs

Need help with the website? Have feedback? Post it here.

Server Migration and Forum Bugs

Postby socheat on Mon May 12, 2003 10:42 am

Really sorry about the long down-time, guys. Ran into a couple minor snags. But the forums are back up now, as well as the main site. We've also taken the time to upgrade the forums to phpBB 2.0.4, rebuilt the search index, and made steps towards setting up a mirror site so that we can avoid such long down-times in the future.

Use this topic for posting any bugs you may come across. Thanks again for being so patient.

Socheat
Last edited by socheat on Mon Mar 21, 2005 6:09 pm, edited 1 time in total.
User avatar
socheat
CD-RW Player
 
Posts: 442
Joined: Wed Aug 01, 2001 8:00 pm
Location: Ann Arbor, MI

Postby cfitz on Mon May 12, 2003 12:15 pm

Thanks for all your efforts, Socheat. I know things like this can be a hassle, and I imagine you were none too happy when you ran into those snags. But it looks like your hard work paid off. I've had no problems navigating the forums, and even better, I've done a number of searches that worked without a hitch! :D It seems that searching is working well now, so maybe soon we will be able to take down the "Search is Broken" thread.

cfitz
cfitz
CD-RW Curmudgeon
 
Posts: 4572
Joined: Sat Jul 27, 2002 10:44 am

Postby BuddhaTB on Mon May 12, 2003 12:40 pm

Thanks Socheat for the upgrade and fixing the search function. :D
User avatar
BuddhaTB
CD-RW Player
 
Posts: 1865
Joined: Thu Aug 22, 2002 8:50 pm
Location: Southern California (LA & Orange County)

Postby MediumRare on Mon May 12, 2003 1:44 pm

Nice work! Thank you. It seems to be faster too (as far as I can tell with my dial-up line). :D

G
User avatar
MediumRare
CD-RW Translator
 
Posts: 1768
Joined: Sun Jan 19, 2003 3:08 pm
Location: ffm

Postby MonteLDS on Mon May 12, 2003 5:35 pm

glad to have the board back :)
User avatar
MonteLDS
CD-RW Player
 
Posts: 989
Joined: Fri Nov 08, 2002 2:32 pm
Location: San Fran Bay Area CALIFORNIA

Postby Boone on Tue May 13, 2003 1:29 am

If it weren't for Socheat you'd be forced to see Ian's HTML skills. He even had to hire this done, but I heard he had a hand in the color scheme:
http://web.archive.org/web/19991008211708/http://www.cdrzone.com/ :o
User avatar
Boone
CD-RW Player
 
Posts: 139
Joined: Sun Apr 08, 2001 2:34 pm
Location: Wisconsin

Postby Ian on Tue May 13, 2003 7:37 am

No, no, no.. I had nothing to do with that design. That was all Dan and George.
"Blu-ray is just a bag of hurt." - Steve Jobs
User avatar
Ian
Grand Poobah
 
Posts: 14882
Joined: Sun Apr 08, 2001 2:34 pm
Location: Madison, WI

Postby cfitz on Tue May 13, 2003 9:20 am

Socheat, look here for the source of the syntax errors that some people are reporting:

http://www.cdrlabs.com/phpBB/viewtopic. ... 5057#65057

cfitz
cfitz
CD-RW Curmudgeon
 
Posts: 4572
Joined: Sat Jul 27, 2002 10:44 am

Postby cfitz on Tue May 13, 2003 11:14 am

Ian, I'm not sure, but I think you may have broken something while fixing the script error. Every since you made the change, the postings and threads that I have read no longer are marked as read. In other words, the little orange "new content" icons remain "lit":

Image Image

Anyone else seeing this problem?

cfitz
cfitz
CD-RW Curmudgeon
 
Posts: 4572
Joined: Sat Jul 27, 2002 10:44 am

Postby cfitz on Tue May 13, 2003 11:16 am

Figures... right after I posted the above post, the problem seems to have gone away. :-? Did you guys do something, or am I hallucinating?

cfitz
cfitz
CD-RW Curmudgeon
 
Posts: 4572
Joined: Sat Jul 27, 2002 10:44 am

Postby Ian on Tue May 13, 2003 12:49 pm

Is the time off for anyone else?
"Blu-ray is just a bag of hurt." - Steve Jobs
User avatar
Ian
Grand Poobah
 
Posts: 14882
Joined: Sun Apr 08, 2001 2:34 pm
Location: Madison, WI

Postby cfitz on Tue May 13, 2003 2:21 pm

Let me see if it is off. Now that you mention it, and looking back at my posts where I described the new/old post problem, I think that might have been the cause.

cfitz

<edit> The time is okay when I posted this post (and new/old is working properly) </edit>
cfitz
CD-RW Curmudgeon
 
Posts: 4572
Joined: Sat Jul 27, 2002 10:44 am

Time Zone

Postby MediumRare on Wed May 14, 2003 9:08 am

Somewhen in the last 2 hours the default time zone (for those not logged in) jumped from GMT to EST. This was a bit disconcerting. :o I don't normally log in during the day (at work) and stayed on GMT otherwise to avoid flipflops in the post times.

I can live with either time zone- as long as it doesn't change more than once or twice a year. :-?

This may be more of a problem to North American users with a customized time zone and subsequent time deltas of 1 or 2 hours than to European or Asian users, where a time difference of > 5 hours is pretty obvious.

Incidentally, I don't believe this (EST):
Most users ever online was 159 on Tue May 13, 2003 9:17 am

G
User avatar
MediumRare
CD-RW Translator
 
Posts: 1768
Joined: Sun Jan 19, 2003 3:08 pm
Location: ffm

Postby Ian on Wed May 14, 2003 10:05 am

I think Socheat was trying to fix the time. I don't know about you, but it was about an hour off for me.
"Blu-ray is just a bag of hurt." - Steve Jobs
User avatar
Ian
Grand Poobah
 
Posts: 14882
Joined: Sun Apr 08, 2001 2:34 pm
Location: Madison, WI

Postby MediumRare on Wed May 14, 2003 10:40 am

Ian wrote:I think Socheat was trying to fix the time. I don't know about you, but it was about an hour off for me.

I can't swear by it, but I **think** it was OK. There may have been some fufla about daylight saving time (although Americans are usually more on the ball about time zones than Europeans). I know CDFreaks claim they run by GMT, but they don't: they're on British summer time.

G
User avatar
MediumRare
CD-RW Translator
 
Posts: 1768
Joined: Sun Jan 19, 2003 3:08 pm
Location: ffm

Postby Han on Wed May 14, 2003 3:38 pm

System clock runs one hour slow...
User avatar
Han
CD-RW PiMP
 
Posts: 569
Joined: Sun Apr 08, 2001 2:34 pm

Postby cfitz on Wed May 14, 2003 4:03 pm

The server clock is running spot on for me. Check your time-zone setting in your profile (or at the bottom right corner, just below the last post on this page). It might not be right.

cfitz
cfitz
CD-RW Curmudgeon
 
Posts: 4572
Joined: Sat Jul 27, 2002 10:44 am

Postby Ian on Wed May 14, 2003 4:41 pm

I have mine set for GMT - 6 (CST) and its an hour slow.
"Blu-ray is just a bag of hurt." - Steve Jobs
User avatar
Ian
Grand Poobah
 
Posts: 14882
Joined: Sun Apr 08, 2001 2:34 pm
Location: Madison, WI

Postby socheat on Wed May 14, 2003 5:24 pm

Apparently phpBB 2.0.x doesn't support DST which is our current problem (previously, the server time was off). See this thread on the phpBB forums:

See this thread

We have four options: deal with the difference until 2.2 is released, everyone adjust their timezone to compensate, install a mod that gives the forum members the option to turn on and off DST at will, or I can change everyone's timezone to match twice a year to adjust.

Socheat
User avatar
socheat
CD-RW Player
 
Posts: 442
Joined: Wed Aug 01, 2001 8:00 pm
Location: Ann Arbor, MI

Postby cfitz on Wed May 14, 2003 6:56 pm

I vote for choice two (everyone adjust their timezone to compensate). After all, not everyone uses daylight savings time.

cfitz
cfitz
CD-RW Curmudgeon
 
Posts: 4572
Joined: Sat Jul 27, 2002 10:44 am

Postby Ian on Wed May 14, 2003 6:59 pm

cfitz wrote:I vote for choice two (everyone adjust their timezone to compensate). After all, not everyone uses daylight savings time.

cfitz


I agree. Maybe just put a sticky somewhere (in the FAQ?) about this so we can point people in the right direction when they ask about it.
"Blu-ray is just a bag of hurt." - Steve Jobs
User avatar
Ian
Grand Poobah
 
Posts: 14882
Joined: Sun Apr 08, 2001 2:34 pm
Location: Madison, WI

Postby dodecahedron on Thu May 15, 2003 3:42 am

i got the following email on Wed, 14 May 2003 19:10:30 -0700 (PDT).
the sender's name is "not there" (there is no registered member of CDRLabs forums under that name, but there is a member named Joker).
Would you please post for me that the board is completely broken for some people (or at least for me). I can't even post to let him know that. If I try to post, or preview a post, or even log out of the board, the only response I can get is an invalid session message. I can see the new posts since the upgrade, but can't do a single thing on the board
other than view posts. I was suprised that it let me view members, so I sorted members by number of posts to find someone that didn't have their e-mail hidden that could post the problem for me. Thanks!

Joker


@Joker:
since you can read this, if you want me to post your email address so that the admins can contact you directly, let me know.
Last edited by dodecahedron on Thu May 15, 2003 2:54 pm, edited 1 time in total.
One Ring to rule them all, One Ring to find them,
One Ring to bring them all and in the darkness bind them
In the land of Mordor, where the Shadows lie
-- JRRT
M.C. Escher - Reptilien
User avatar
dodecahedron
DVD Polygon
 
Posts: 6865
Joined: Sat Mar 09, 2002 12:04 am
Location: Israel

Postby socheat on Thu May 15, 2003 8:52 am

dodecahedron wrote:@Joker:
since you can read this, if you want me to post your email address so that the admins can contact you directly, let know.


A private message would be preferred. :)
User avatar
socheat
CD-RW Player
 
Posts: 442
Joined: Wed Aug 01, 2001 8:00 pm
Location: Ann Arbor, MI

Postby CDRecorder on Thu May 15, 2003 9:01 am

Socheat wrote:We have four options: deal with the difference until 2.2 is released, everyone adjust their timezone to compensate, install a mod that gives the forum members the option to turn on and off DST at will, or I can change everyone's timezone to match twice a year to adjust.


I would vote for option 2 as well.
CDRecorder
CD-RW Recorder
 
Posts: 2335
Joined: Tue Apr 01, 2003 9:28 pm

Postby MediumRare on Thu May 15, 2003 3:04 pm

Socheat wrote:
dodecahedron wrote:@Joker:
since you can read this, if you want me to post your email address so that the admins can contact you directly, let know.


A private message would be preferred. :)

You admins must have an e-mail adress for the board members- why not send him a mail with a return adress to clear things up ?

G
User avatar
MediumRare
CD-RW Translator
 
Posts: 1768
Joined: Sun Jan 19, 2003 3:08 pm
Location: ffm

Next

Return to Feedback and Help

Who is online

Users browsing this forum: No registered users and 0 guests

All Content is Copyright (c) 2001-2017 CDRLabs Inc.