Page 1 of 1

Firmware file for a DRCDRW401248 (BenQ 4012P) ?

PostPosted: Mon Mar 15, 2004 10:14 am
by JamesJ
I'm looking for a plain firmware file for a Digital Research DRCDRW401248 CD-RW drive, which seems to be a relabelled BenQ 4012P. Not the BenQ firmware programs, put a plain firmware file, suitable for use with MTKFLASH.

Here's the situation.

I had an Artec DVD-ROM drive as secondary master and the CD-RW drive as secondary slave. Both were working. I decided to update the firmware on the DVD-ROM. I d/l'ed the flash utility ( and a DVD-ROM firmware file ( from the Artec Web site. I assumed I would use the flash utility to write the firmware to the DVD-ROM drive. contained ArtecDHM.exe, G48-297.bat and G48V297.HEX . No instructions at all.
The instructions for flash5.20a referred to a "bin" file, but there wasn't one of those in . I figured the BAT file must be used to create a BIN file for the flash5.20a, so I tried to run it. It seemed to get stuck when I tried to run it under Windows, so I booted to DOS and ran it there. This time it ran and seemed to finish OK. When I rebooted the computer, both the DVD-ROM and CD-RW were dead. The BIOS didn't see them and the eject buttons had no effect.

What I know now:

The batch file runs a program called ArtecDHM.exe . It turns out that this is a renamed copy of MTKFLASH v 1.48. Apparently they don't use flash5.20a to flash the DVD-ROM firmware.
The batch file tells ArtecDHM (MKTFLASH) to write to drive 4 (secondary slave). Someone at Artec really screwed up there. That would be bad enough, but since they had renamed MTKFLASH.EXE to ArtecDHM.exe and included absolutely no documentation, I had no idea what the batch file was trying to do, much less that it was going to try to write to the wrong drive.

Once I knew that ArtecDHM was really MTKFLASH, and having read that using MTKFLASH with two CD drives on the same controller could cause a bad flash, I disconnected the CD-RW drive and ran ArtecDHM with the correct drive number and the DVD-ROM drive seems to be working again (all I've done so far is list the contents of a CD-ROM). FWIW, before I ran ArtecDHM to fix the firmware, I used MTKFLASH to save the current (bad) firmware in a file. Once I got the DVD-ROM drive working again, I disconnected it and made the CD-RW secondary master to see what I could do with it.

I'm hoping that I can fix the CD-RW drive in the same way, but I need a firmware file to use with MTKFLASH. I don't see any firmware on the DR Web site and all of the BenQ 4012P firmware I can find on the 'Net is in EXE files. I'll try any V.xW version. I just want something that gets the BIOS and Windows to see the drive again, after which I can (presumably) use BenQ's Windows flash program to update to the latest firmware. BTW, just in case it might be of some use, I used MTKFLASH to save the current (bad) CD-RW firmware in a file. Wish I'd done that before all this, but in my defense, I was trying to update the DVD-ROM firmware, not the CD-RW firmware, and didn't realize that that stupid BAT file was trying to flash the firmware.

In searching this forum, I see that OC-Freak was once looking for BenQ 4012P firmware. He said that he was able to get one from the guy that wrote Litefirm. I haven't tried to contact that guy. I have looked around his site and didn't see any BenQ firmware there. Just for the heck of it I tried Litefirm with the BenQ firmware programs. It couldn't find any firmware in the Windows programs, but it actually did seem to find firmware in the DOS programs for some of the older firmware versions. It identifies it as BenQ firmware and creates a 256 KB file. However, I've tried MTKFLASH with the files that Litefirm extracted from vkw-dos.exe, vmw-dos.exe and vrw-dos.exe and none of them worked. In each case, MTKFLASH ran to 100 %, said "Bank 0 OK", ran to 100 % again, said "Bank 1 OK", ran to 100 % again, said "Bank 2 OK", then ran to 50 % and stopped. It hangs there and goes no further. I've left it for 10 minutes with no change. And when I use Ctrl-Alt-Del to kill MTKFLASH and reboot, the BIOS still doesn't see the drive.

I'm hoping that the problem is the firmware files that Litefirm extracted (since it's mainly for Lite-On firmware) and that with a good firmware file, MTKFLASH will work and fix this drive.

FWIW, I went to the DR Web site and submitted a support request there asking for a firmware file (or any other suggestions they might have), but it may take a while to hear back from them, so I thought I'd go ahead and ask here as well. I started to try to contact BenQ, since it's their firmware, but since the drive was sold by DR, I figured I should ask them instead.

I guess that's it. Any thoughts?


Re: Firmware file for a DRCDRW401248 (BenQ 4012P) ?

PostPosted: Mon Mar 15, 2004 12:38 pm
by MediumRare
JamesJ wrote:In each case, MTKFLASH ran to 100 %, said "Bank 0 OK", ran to 100 % again, said "Bank 1 OK", ran to 100 % again, said "Bank 2 OK", then ran to 50 % and stopped. It hangs there and goes no further. I've left it for 10 minutes with no change. And when I use Ctrl-Alt-Del to kill MTKFLASH and reboot, the BIOS still doesn't see the drive.

I don't know if it helps, but I had some problems unpdating the firmware in my LiteOn LTR48246S just after I bought it. The official flashers wouldn't work and the then newest version 1.55 of MTKFlash didn't work either- similar to what you are seeing.

In my case, using an older version (1.48) did the trick. Sometimes a newer version may help as well. Dave (dhc014)has an good howto on his site, along with links to various versions.

Good luck with your drive.


PostPosted: Mon Mar 15, 2004 3:07 pm
by JamesJ
Thanks for the reply.

I was using version 1.48 of MTKFLASH. Maybe I'll try a different version. Couldn't hurt (I presume). And I'll look at the "how to flash" page you posted the link to. Actually, I had it in my head to look for more info on running MTKFLASH, but then forgot about it. Thanks for the reminder.


PostPosted: Mon Mar 15, 2004 10:53 pm
by JamesJ
"It's alive!!!!"
"Happy, happy, joy, joy." :-)

Yes, I got the CD-RW working again.

For anyone that might be interested, here's what I did.

I looked at the MTKFLASH "how to" page that MediumRare suggested, but didn't see any really new info there on the basics for using MTKFLASH. The page recommended version 1.55 or, if that fails, 1.80.1. I d/l'ed both and tried them with some of the firmware files that Litefirm had extracted from the BenQ DOS firmware programs. Same problem. They would count to 100 % for banks 0, 1 and 2 and say that each of them was, in turn, OK, then count to 50 % of bank 3 and stop. I'd give them a couple minutes and nothing. The only difference I saw was that when 1.80.1 stopped at 50 %, it totally locked the computer and I had to reset. When 1.48 and 1.55 stopped, I could use Ctrl-Atl-Del to reboot (Ctrl-C didn't work).

MTKFLASH _was_ communicating with the CD-RW drive. Aside from the fact that it was apparently writing the first 3 banks with no problem, I could use MTKFLASH to read the firmware from the drive. The only IDE devices connected at that time were a hard drive and the CD-RW, so MTKFLASH wasn't talking to another CD drive. When I used the "C" (Check) option, MTKFLASH reported the following:

MTKFLASH By Joseph Lin (Ver 1.80.1)

ManuId : ad ManuId1 : 0 bDevId : b0

Flash Type : HYUNDAI(HY29F002T)

I noticed that when I compared the firmware file that MTKFLASH had just read from the "dead" CD-RW drive with the firmware file that I tried to flash, the files were the same until byte 38001 (hex). That is 7/8 of the 256 KB file, or 3.5 out of the 4 banks (assuming all 4 banks are the same size). That would seem to confirm that MTKFLASH was writing the first 3 banks and 50 % of the 4th.

I wasn't really sure what that told me, but it did suggest one possibility. The firmware version I was using before this was V.TW. Looking at the bad firmware file that MTKFLASH read from the "dead" CD-RW, at least some of the data in that last 1/8 was intact. I could still see the V.TW version number near the end, for example, which I knew was a leftover, because I had no V.TW firmware file to try to use with MTKFLASH. If the last 1/8 was intact (because MTKFLASH and ArtecDHM.exe, which was really MTKFLASH v1.48, had never overwritten it) and I could use MTKFLASH to flash version V.TW, then the fact that it couldn't/wouldn't write the last 1/2 of bank 4 might not be a problem, since that part may already (or still) be there. But I didn't have a V.TW firmware file. The only BenQ V.TW firmware I've found is the Windows program, and Litefirm doesn't see the firmware in that file (it only worked on the DOS versions of some older BenQ firmware programs).

So then I decided to see if I could extract the firmware from VTW.EXE myself. I hadn't considered trying that before because I had just assumed that it wouldn't be that easy to do, but it was actually quite simple (given the proper experience and tools). I've been working with computers for over 20 years, mostly running Unix. In that time I've looked at countless "binary" files looking for data of one sort or another.

I looked at the firmware files that Litefirm had extracted from the DOS firmware programs, found a distinctive string near the beginning of each one, found that string in VTW.EXE, backtracked from there to the likely start of the firmware data and extracted 256 KB of data from VTW.EXE, starting at that point. Finding and extracting the data probably took around 5 - 10 minutes. Then I used MTKFLASH to flash that firmware file to the CD-RW.

The first time I tried was with MTKFLASH version 1.48 (or maybe 1.55) and I got errors. I don't know if the problem was me (bad command options) or the program. I _thought_ I entered the command correctly, but maybe not. So then I used version 1.80.1 and it ran as before, counting to 100 % for banks 0, 1 and 2 and then stopping at 50 % in bank 3. I gave it a minute or two and hit reset. Sweaty moment as the CD-RW still didn't seem to be responding, but then I turned off the computer and when I powered it back on, the LED came on. The BIOS saw the drive, no problem. I booted Windows, which also saw the drive, and ran BenQ's VTW.EXE to make sure the firmware was correctly flashed. VTW.EXE saw the drive and reported no problems flashing it.

I can look at the contents of a CD-ROM and burned a few files to a CD-RW disk with no problem. Another small sweaty moment when Nero's InfoTool said that the maximum write speed was 4X and read speed was 30X, instead of 40X and 48X. But, as I had hoped, that was because of the CD-RW disk I had in the CD-RW drive at the time. With a CD data disk or CD-R, they went back to 40X and 48X.

I've got the DVD-ROM and CD-RW back in place as secondary master and slave and both seem to be working fine now. Gee, what fun. :-)

So, the key, at least for me, seems to have been that the versions of MTKFLASH that I've tried can't, or won't, write the last 50 % of bank 3 (the 4th bank). That meant that that part of the original firmware was not changed, and could not be changed, by MTKFLASH, so I had to use MTKFLASH to reflash the first 3.5 banks with the firmware that matched the last 50 % of the 4th bank.

I'd be happy to email any of these extracted BenQ firmware files to anyone that's interested, but I don't know if they should be just posted on a Web site, since, based on my experience, trying to use MTKFLASH to flash anything but the firmware version that you were already using won't work. Posting the firmware files on a Web site without an explanation is just asking for trouble. Also, for the record, I have no way of knowing if most of these firmware files are actually good. It's a pretty good bet that the V.TW file is good, since that one got my drive working again (because that was the version that the CD-RW was using before this started). AFAIK, the other firmware files are fine, but I don't have any proof of that. I could try flashing with a BenQ firmware program (eg. VMW.EXE) and then use MTKFLASH with the corresponding firmware file (eg. vmw.bin) and see if the drive still works, but I'm not that dedicated. :-)


PostPosted: Mon Mar 15, 2004 11:21 pm
by dodecahedron
very well done! :D

PostPosted: Tue Mar 16, 2004 12:18 am
by JamesJ
Thanks. I'm just glad I got them both working again.


PostPosted: Tue Mar 16, 2004 1:54 am
by MediumRare
Great. Shows what a bit of logical thinking can do!