Page 1 of 1

Stuck in PIO Mode 4 at BIOS Level

PostPosted: Tue Nov 04, 2003 10:45 pm
by AlexScott
Hi guys.

This problem has absolutely baffled me! I'm having problems enabling DMA mode on my (perfectly capable) system. The problem is at the BIOS level, even before my operating system starts. At the summary page it states that my LG GCC-4480B Combo drive is running at PIO 4. However, I know the drive can go faster because I've had it for a while.

The problem started when I performed an experiment. The drive was set to secondary slave with another CD drive on master. I swapped them around, making sure to change the jumpers on each drive, to see if this would make the drive go any faster. Since then, I've been unable to get out of PIO mode. (Incidentally, the other drive, an old 4x CD Writer, runs in Multiword DMA Mode!)

Here are my system specs:
Gigabyte 7VAXP Ultra Motherboard (Via KT400)
Athlon XP 2000+ Processor
Primary Master: 40gb Generic Hard Drive, Running in DMA fine
Primary Slave: Zip 250, Running in DMA fine
Secondary Master: GCC-4480B, the problem drive
Secondary Slave: TEAC 4x CDRW, running in DMA fine
IDE3 Master: 120gb Maxtor HD, Running in DMA fine
Using 80pin cable for all drives
Running Win XP Pro

And here's what I've tried so far:
All the advice in this forum relating to enabling DMA in the OS
Reinstalling Windows XP
Running the drive as Secondary Slave
Runnning the drive as Secondary Master with no slave drive
Using 40-pin cable supplied with the drive (Comp doesn't start)
Changing the jumpers on both drives to Cable Select
Running the drive on IDE4 Master, alone (Cannot read or write CDs)
Made sure PIO and DMA modes in motherboard were set to 'Auto'
Updating the BIOS to the most recent version
Clearing the DMI and PnP data pools on the BIOS
Clearing the CMOS by removing and replacing the battery (no clear switch)
Updating my VIA 4in1 drivers, and using the ones supplied with WinXP

If anybody can help me with this, I will be in their debt. My flatmate is also having exactly the same problem, but with different hardware. I can't burn CDs faster than 16x, and doing so uses 100% of my CPU and sometimes produces 'coasters'.

Please please help!


PostPosted: Wed Nov 05, 2003 2:58 am
by CDRecorder
Welcome to CDRLabs! :D

Did you try clearing your CMOS settings using the jumper on the motherboard?

PostPosted: Wed Nov 05, 2003 5:28 am
by AlexScott
I'm not sure how to do that - I'll have to check my motherboard manual. Is there a way to do it with software that doesn't need me to open my computer up?



PostPosted: Wed Nov 05, 2003 11:50 am
by CDRecorder
Unfortunately, I don't know of any way it can be done without opening up the computer. Your motherboard manual should tell you what you need to know.

PostPosted: Wed Nov 05, 2003 8:41 pm
by AlexScott
Okay, I've tried clearing my CMOS (there was no jumper or switch so I had to remove the battery for a few seconds).

No luck. All the settings in my BIOS returned to their defaults but alas, no ATA mode!

Any further suggestions? Thanks for your help so far.


PostPosted: Wed Nov 05, 2003 10:22 pm
by CDRecorder
Maybe your IDE cable is bad. Try the new cable that you mentioned before. The reason your computer didn't start when you tried it before is almost certainly because you plugged it in backward (years ago, I did the same thing with the same result).

PostPosted: Wed Nov 05, 2003 10:44 pm
by AlexScott
Definitely not the cable. When I tried the 40pin cable that came with the drive, it would only go in one way anyway. I've tried more than one 80pin cable as well.

I appreciate the help so far!


Re: Stuck in PIO Mode 4 at BIOS Level

PostPosted: Thu Nov 06, 2003 12:44 am
by CDRecorder
AlexScott wrote:My flatmate is also having exactly the same problem, but with different hardware.

I'm curious; what drive and motherboard is he having this problem with?

Have you tried updating the firmware on your drive? I don't see how this could help, but it's always possible...

Also, have you tried installing this drive into another computer to see if it will run in DMA mode there?

PostPosted: Thu Nov 06, 2003 10:38 am
by Han
Teac 4x CDRW drive actually doesn't support UDMA Mode 2, it's perfectly normal that it operates in MultiWord DMA.

I'd try your LG combo in another PC on a drifferent motherboard brand. If it won't run in DMA mode, replace it if it's still under warranty.

PostPosted: Fri Nov 07, 2003 6:05 am
by AlexScott
I've tried replacing the drive with another (same make and model) but this has had no effect - same problems!

I'm going to try the drive in someone else's computer and see what happens.

I've tried updating the firmware but the procedure fails (when I had DMA working, updating worked too). I don't think there's a huge difference anyway - 1.00 to 1.02.

My flatmate is running a 20x CD-RW on an ABit motherboard and has the same issues (he can only write up to 12x). I can't give you any more details than that at the moment.

What could we both have done to our respective motherboards to cause the problem? This is really baffling!

Thanks guys so far!