Page 1 of 1

Stuck in PIO mode?

PostPosted: Tue Sep 18, 2007 12:02 pm
by cosmichippo
Recently had some odd behaviour from my system.

I have a BenQ 1650 in a Compaq system. It is on the second IDE channel and is second on the cable (slave). There is a Liteon 52X CDRW on the 2nd channel as the master.

What happened is this. I was ripping a video DVD with the Benq and is had a dirty place at the extreme outer edge that I hadn't noticed. The rip failed a couple of times with different rippers after trying repeatedly for several minutes at the end. After that I noticed the dirty area and cleaned it up. The disc was playable after that in MPC although it was jerky. Tried to rip it again and it began at a very slow rate and never sped up. It was also pegging the CPU usage at a constant 100%.

I uninstalled all the ripping software and Nero and checked the system ASPI. Reinstalled Nero and still the drive acts the same. Reads and burns at .9-1.3X and uses 100% CPU. I completely removed and uninstalled the Benq and rebooted a couple of times. Reinstalled still the same.

Then I started checking system setting that shouldn't have changed. MB BIOS was still Ultra DMA enabled. When I got to the secondary IDE channel in the device manager the master drive was DMA if available and DMA was detected and selected. On the 2nd drive on the secondary it said PIO only na dobviously PIO was selected automatically. I changed it to DMA if available and rebooted. It still selected PIO and I can't get it to change back to DMA.

Did the difficult rip do something to my drive or is there something obvious that I am missing as far as setting it back to DMA?

Sorry for the long post but I thought the details were necessary to describe what was wrong and what I had done so far to fix it.

Thnaks for any suggestions in advance,

PostPosted: Tue Sep 18, 2007 12:52 pm
by Justin42
Yes, the rip most likely caused it. Windows has a wonderful "feature" that if it detects too many errors it drops your drive down to PIO and forces it to stay there.

Read this for help fixing it:

PostPosted: Tue Sep 18, 2007 10:06 pm
by cosmichippo
Thanks Justin. That did the trick. I guess that I should have searched around the site a bit more but figured that this was an obscure, rare problem. I had already removed and uninstalled the drive but it hadn't occured to me to go as far as the IDE controller driver.

Anyway, thanks again,