Page 1 of 1

BluRay player suddenly stopped playing BD-R movies

PostPosted: Tue Nov 07, 2017 9:53 am
by jellyhead
I have 2 BluRay players, one is a Samsung BD-C6800 the other LG BP620C. I've been using the BD-C6800 as my main player because it doesn't detect Cinavia. Suddenly one day it just stops playing any of my burned BluRay movies. what's odd is it will play them perfect the first time I put them in, then every time after that I get the unknown disc error. At first I thought it was just a problem with the memory but now I'm not so sure after the following has happen. Because my burned movies no longer play in the BD-C6800, I swapped the BP620C to use as my main player which does detect Cinavia. It was playing everything perfect as it always had except for Cinavia protected discs. I had read some players had released updates which disabled Cinavia so I decided to try updating it. Wouldn't you know it, after the update now this player will no longer play burned BluRays????? WTF is going on here? has the motion picture industry gotten the electronics companies to do their dirty work and put a stop to movie copying?

Most of my movie are burned on PlexDisc 633-C13 media code OTCBDR002, I believe they are HTL. I use BD Rebuilder to shrink them down to BD25 and ImgBurn latest version set at UDF 2.50. Most are full discs with extras blanked, some are movie only copies but it doesn't seem to make any difference. As I said, they all worked perfect then suddenly after the update NONE are woking.....any ideas on this?

Re: BluRay player suddenly stopped playing BD-R movies

PostPosted: Wed Nov 08, 2017 5:59 pm
by Ian
How old is the BD-C6800? I'm wondering if the laser is losing power and with BD-R discs being less reflective, it can no longer read them. The works at first situation thinks it might be heat?

I'm not sure about the BP620C and the update disabling support for burned Blu-rays.

Re: BluRay player suddenly stopped playing BD-R movies

PostPosted: Wed Nov 08, 2017 9:44 pm
by jellyhead
Yeah, the BD-C6800 got worse over time but then suddenly would only read on the first play. That doesn't make sense to me, if they work once they should work every time. The BP620C worked perfect right up until the update, downgrading the an older firmware enabled the BD25s to play but the BD50s still don't work. I made sure the driver version downgraded as well as the software but still they don't work.