Page 1 of 1

Load of CD not recognized by Windows Explorer

PostPosted: Thu Jan 01, 1970 4:33 am
by mer1039
I am running Win 98 SE and have a Yamaha 3200 CDRW (EIDE 24x write, 40x read). It is set as the slave on my primary IDE cable. I am running into a problem where Windows Explorer will not recognize the load of a new CD. Here are some details:

I would load an audio cd into the CDRW. I can go to Windows Explorer and see a list of the files on the CD. I play the audio CD with Music Match or Windows Media player. No problem yet. Then I eject the CD and put in a data CD. If I go to Windows Explorer and refresh the screen I still see the file list from the audio CD not the newly loaded data CD. Closing Windows Explorer and re-opening it does not clear the problem, the old file list still appears. Had to restart the PC to before I can correctly see the data files in Windows Explore of the data CD in the Yamaha CD drive.

Any Ideas as to what might be causing this problem? Or places to further research symptom?

PostPosted: Wed Dec 10, 2003 8:52 am
by Deckard
Searching through these forums for a solution to my problem I finally found "exactly" the same symptom in this thread:
When I swap CD in my drive, the old CD keeps showing up. If I deactivate/reactivate the drive the new CD shows up but no amount of refreshing, ejecting/inserting helps.
I don't have a CDRW though (it's a standard Sony 52x reader) and I'm running XPsp1 on a new Abit NF7-S 2.0 motherboard with latest BIOS 2.0 and drivers from Abit. (I'm not at home now so I don't have any exact model descriptions)

However, I notice that no replys has been made to this thread so I'm thinking either it's a very simple problem but I'm to stupid to realize that or it is indeed a tricky one.
I'm all new to this so believe me when I say I don't have a clue :o .
I see that there are a lot of talk about enabling the DMA, so I will see if that is on or not and if it can resolve my problem.

If anyone has any ideas I'll of course be happy to receive some advice!

PostPosted: Thu Dec 11, 2003 5:30 pm
by MediumRare
Make sure that "Auto-Insert Notification" is enabled for the drive. You can check this with the "properties" tab for the drive in the device manager. (I'm running a German version of Windows (95 and XP), so I'm not sure if I got the exact name for these settings right, but it'll be close to this.)

Sometimes you hear recommendations to turn this off while burning because it can interrupt the data stream while the disk is being recognized, but with the anti-coaster features (Burnproof / Seamless Link etc.) of modern burners, this is not a big deal anymore.


PostPosted: Sat Dec 13, 2003 8:11 am
by integspec
Guys, try this: ... roduct=w98

(KB 312475)

I once had the same issue but unfortunately don't remember how I solved it. But I think the registry hack to enable Autorun should solve your problem.

Good luck.