Page 1 of 1

Need help recovering a RAID volume!

PostPosted: Wed Dec 17, 2003 3:15 pm
by BurninMan921
OK, I have two 60GB hard drives that were striped into a RAID 0 by Windows 2000 - they were software RAID, not hardware.

Now then, I tried to install WinXP, but it gave me an error saying that "one or more disks were identical and could not be accessed. Windows has repaired the problem."

It's "repair" of the problem involved deleting the partition tables from ALL of the HDD's in my system except for the main drive! Stupid POS!! This is why I hate Windows so much! If stupid Agent and Nero had Linux versions, I'd NEVER touch Windows again!

Anyway, I was able to undelete the partition table on my non-raid hard drive with TestDisk (great little program!!), but it won't recoginize the partitions on the RAID drives - I'm guessing that the Windows "dynamic disks" RAID mode writes the table across both drives, and since it's software not hardware raid, TestDisk can't "see" the full parition table.

So...anyone know of a program to recover that partition?
I'd really like my 60+GBs of data back!

Only one of the two raid drives was hosed; Partition Magic sees the one correctly as a dynamic disk, but shows the other drive as being unallocated, and says there are no partitions to undelete. :(

PostPosted: Wed Dec 17, 2003 4:31 pm
by BurninMan921
From Microsofts web site:

o Recover a Deleted NTFS Volume
Re-create the exact same volume but choose not to format it. This may be difficult if you do not remember the exact size you had created originally, especially because the Disk Management snap-in tends to round partition sizes.
Using Dskprobe.exe, recover the backup boot sector for the NTFS volume from the end of the volume. Because it is a dynamic volume you may need to use Dmdiag.exe to help find the backup boot sector, or search for it by using Dskprobe.exe (on the Tools menu, click Search Sectors).
After rewriting the NTFS boot sector, quit Dskprobe.
In Disk Management, click Rescan Disks on the Action menu. This should mount the volume for immediate use.

Argh! That does NOT work! Sectors recovered ok...

PostPosted: Thu Dec 18, 2003 8:05 am
by integspec
Long time ago I recoverd a RAID 5 volume of 3 HDDs. The OS drive (4th and seperate drive) went bonkers and and lost the registry info for the RAID volume. What we did was, Installed NT4 Server fresh in a different HDD (same like original setup, OS in one dedicated drive and 3 disks for RAID)and used a utility from NT 4.0 Reseource Kit.

Have you tried plugging both RAID drives to a Win2k PC? AFAIK, Win2k will not recognise the volume by default but if you have the Reskit you can use this utility. (I have to get back to Office tomorrow to check on the Win2k Reskit).

Btw, usually in a situation like this it would be safe to leave the drives of RAID volume alone and try to get them recognised in the OS drive (ie: perform troubleshooting on an inedependent OS drive which doesn't belong to the raid pool).