Home News Reviews Forums Shop


Problems enabling DMA in Windows XP

Answers To Frequently Asked Questions

Problems enabling DMA in Windows XP

Postby dodecahedron on Thu Jan 01, 1970 5:31 am

the problem:
when trying to enable DMA in windows XP
(Device Manager: IDE ATA/ATAPI controllers -> Primary/Secondary IDE Channel -> Advanced Settings tab -> Device 0/1, Transfer Mode pull-down menu, choosing "DMA if available".
for detailed instructions look here: How to enable DMA in Windows XP (with pictures))
windows refuses to enable DMA, stays in PIO mode.

a possible solution:
to uninstall that IDE channel (right click Primary/Secondary IDE Channel -> Unintsall)
BE VERY CAREFUL your OS drive isn't on the channel your'e uninstalling!!!
then scan for new hardware (Action -> Scan for hardware changes), and let windows redetect and reinstall the IDE channel and the devices on it.
usually after this operation selecting "DMA if available" enables DMA.

Note:
some members of the forum reported that it is possible to uninstall the IDE channel on which the OS drive is located without problems. after doing so windows asks for a reboot after which it redetects and reinstalls the IDE channel. i have'nt tried this myself (yet) though. so do it at you own risk.
Last edited by dodecahedron on Tue Jan 21, 2003 7:29 am, edited 5 times in total.
One Ring to rule them all, One Ring to find them,
One Ring to bring them all and in the darkness bind them
In the land of Mordor, where the Shadows lie
-- JRRT
M.C. Escher - Reptilien
User avatar
dodecahedron
DVD Polygon
 
Posts: 6865
Joined: Sat Mar 09, 2002 12:04 am
Location: Israel

Postby dodecahedron on Thu Jan 01, 1970 6:00 am

another solution:
minchin wrote:First, set the device that keep stuck in PIO mode to PIO mode only. Reboot.
Then set the device again to Use UDMA if available. Reboot.... Wowlah! The hard drive is no in UDMA mode!
One Ring to rule them all, One Ring to find them,
One Ring to bring them all and in the darkness bind them
In the land of Mordor, where the Shadows lie
-- JRRT
M.C. Escher - Reptilien
User avatar
dodecahedron
DVD Polygon
 
Posts: 6865
Joined: Sat Mar 09, 2002 12:04 am
Location: Israel

Postby cfitz on Thu Mar 06, 2003 2:22 pm

And another alternative, courtesy of Han with some additional elaboration by Null (this applies to both XP and 2000):

If deleting the IDE channel and your burner from Device Manager doesn't help, open the Registry (Start -> Run -> Regedit) and open the following key:

HKEY_LOCAL_MACHINE \ SYSTEM \ CurrentControlSet \ Control \ Class \ {4D36E96A-E325-11CE-BFC1-08002BE10318}

Within this key you will find several subkeys. Most likely you will see the following:

0000 (for the IDE controller)
0001 (for the Primary IDE channel)
0002 (for the Secondary IDE channel)

Each of these subkeys has a named valued called "DriverDesc" that will make it clear to you to which component they correspond. Open the subkey corresponding to the channel on which your troublesome drive is located. Then, if the troublesome drive is the master, delete the "MasterIdDataChecksum" named value. Or, if the troublesome drive is the slave, delete the "SlaveIdDataChecksum" named value.

Reboot. The OS will redetect the device DMA capabilities after reboot.

Note that for many older CD-ROM drives DMA can not be enabled in Windows 2000/XP, so be sure to check the capabilities of your particular drive if you continue to have problems.
cfitz
CD-RW Curmudgeon
 
Posts: 4572
Joined: Sat Jul 27, 2002 10:44 am

If you still have problems...

Postby Anne-Cécile Wolf on Wed Mar 26, 2003 5:34 am

Hello ! I tried everything you sais, and it still didn't work... But I finally found a solution, which is installing new drivers for the IDE channels.
I can tell you what can be done for VIA motherboards (I don't know about others) :

-go on the site viaarena.com
- download the VIA miniport drivers
- install them
- reboot your computer... taddaaa !!! It works (although for me only in mutiword DMA mode 2, but it is enough to view my DVDs without anymore problems :wink: )

I guess the same might be done with other motherboards, you need to install some of the latest drivers, check on their website (and on their own forums, the answer might be there... :) )

Good luck to everyone.
AnnC
User avatar
Anne-Cécile Wolf
Buffer Underrun
 
Posts: 3
Joined: Tue Feb 25, 2003 1:54 pm
Location: France

Enable DMA on win XP

Postby Latzab on Thu Jun 12, 2003 1:52 pm

Hello,

I had the same problem but none of the tips here worked for me.

I have my cd-rw (dma33) and my dvd(dma66) on the secondary IDE.

This is what I discovered:

When the settings for the secondary IDE channel in my BIOS are set to NONE/NONE, the OS will not enable DMA33/66 but forced it to MULTI-WORD DMA mode 2.

I changed the settings to AUTO/AUTO and voila!, XP enables DMA33 and DMA66.

Hope this can help.
The difference between genius and stupity is that genius has its limits - Albert Einstein
Latzab
Buffer Underrun
 
Posts: 1
Joined: Thu Jun 12, 2003 12:27 pm

Postby cvermeer on Sat Jan 06, 2007 11:53 pm

Hey Thanks for the info
I have a gsa-h22n with xp and stuck in PlO
I fixed it by deleting the line "SlaveIdDataChecksum" with regedit
Now it I hope it works well
thanks for your help :P
cvermeer
Buffer Underrun
 
Posts: 2
Joined: Wed Jan 03, 2007 11:35 pm

Enabling DMA to resolve choppy playback

Postby bsc249 on Sat Jan 13, 2007 2:27 am

Thanks for the tips guys!!

I've had a Dell Dimension 8300 for about 3 years now and it came with the samsung DVD-Rom SD 616t. I added the Lacie (samsung) internal d2 DVD burner with lightscribe and both were working great for the past year. Recently I started developing choppy/stuttering playback but all other functions were fine.

I came across a post to check my DMA settings and violla: PIO. First tried to update drivers - nuthin... Next uninstall from device manager, reboot - nuthin... Next, change DMA setting's via device mgr as outlined at top of page - reboot - nuthin...

Finally followed cfitz's directions for editing the registry and Presto, All Systems Go.

Thanks for the post!
bsc249
Buffer Underrun
 
Posts: 1
Joined: Sat Jan 13, 2007 1:43 am

Postby dodecahedron on Sat Jan 13, 2007 3:02 pm

you guys aren't reading the FAQ Forum Guidelines.
http://www.cdrlabs.com/phpBB/viewtopic.php?t=19673
the FAQs are for FAQs. not for asking questions, for help or commentary. such posts should be made in other forums (DVD Writers Forum for instance).

your posts will be deleted in a while (a week or so).
One Ring to rule them all, One Ring to find them,
One Ring to bring them all and in the darkness bind them
In the land of Mordor, where the Shadows lie
-- JRRT
M.C. Escher - Reptilien
User avatar
dodecahedron
DVD Polygon
 
Posts: 6865
Joined: Sat Mar 09, 2002 12:04 am
Location: Israel

Postby Iow on Sat Jan 12, 2008 9:25 am

Hi all,

Just wanted to let you know, I experienced the same problem (IDE channel in PIO mode and not able to change it). After many times banging my head on the table finally a IDE/RAID driver update solved the problem. I have a MSI P096 Neo motherboard and downloaded the latest JMicron RAID Drivers from the MSI website. Hope this will help someone.
Iow
Buffer Underrun
 
Posts: 1
Joined: Sat Jan 12, 2008 9:19 am

Re: Problems enabling DMA in Windows XP

Postby Born2Burn on Sat Mar 26, 2011 12:10 pm

Driver updates and registry fixes are almost always the fix for this kind of issue. Otherwise you are going to have to consider disaster recovery software of some kind. I have had about four years of guess and check experience so I stand by my comments. For me it was always an issue of staying poorly organized. I would send you a copy, but for some reason I don't feel as safe using dvd burning codecs for software as I do for movies and shows.
Burn Baby Burn Baby Burn Baby Burn
User avatar
Born2Burn
Buffer Underrun
 
Posts: 9
Joined: Fri Mar 25, 2011 11:55 am


Return to FAQ's

Who is online

Users browsing this forum: No registered users and 0 guests

cron
All Content is Copyright (c) 2001-2018 CDRLabs Inc.