Home News Reviews Forums Shop

problems with DMA


Postby dstonek on Sat Jun 25, 2005 5:49 pm

Last year I bought a DVD-RW unit I installed on my XP SP1. It was sold as Sony even there is no brand printed in front of it. System recognized it as a Sony and it worked fine. I have burned around 100 data DVDs. Last week I upgraded to Service Pack 2 and then DVD is recognized as a LITE-ON 812S. The issue is that the burning time has been cuadruplicated, red light blinks to orange constantly. All the computer slows down while recording during an hour.
I've read and perform lot of things that didn't help.
I installed a firmware from Liteon.
I installed last version of Nero.
I installed last updates of SP2
Microsoft is the driver supplier on both channels.
Intel 82801DB Ultra ATA Controller
At the end it seems DMA is installed on DVD. After uninstalling (reinstalling) secondary IDE channel there is no more 'advanced configuration' tab on device manager but Nero log file says that it is ON (last burn)
I am attaching this log file where you may see some errors during verification.
When reading the disk I cannot find errors (random open image files). Even more, I use cdTree to catalog its content and no errors were found.
After all I only was able to reduce from one hour to 45 minutes recording time instead of usual 15, 4X.
Thanks in advance for a clue.
PS 'Add attachment is not workin fine' I choosed a file, added a comment and pressed 'add attachment' -> there's no attach here
It is HERE http://fotos.stonek.com/images/woDMA.txt
Buffer Underrun
Posts: 5
Joined: Sat Jun 25, 2005 11:01 am
Location: uruguay

Postby dodecahedron on Sun Jun 26, 2005 12:13 am

uninstall Intel's Application Accelerator
One Ring to rule them all, One Ring to find them,
One Ring to bring them all and in the darkness bind them
In the land of Mordor, where the Shadows lie
M.C. Escher - Reptilien
User avatar
DVD Polygon
Posts: 6865
Joined: Sat Mar 09, 2002 12:04 am
Location: Israel

Postby dstonek on Sun Jun 26, 2005 10:16 am

I did it before and XP started with its black screen and "safe mode",.....
I had to start with "previous working startup" (only successful start up) and Intel ultra dma is obviously there.
Why such difference between SP1 and SP2?
Buffer Underrun
Posts: 5
Joined: Sat Jun 25, 2005 11:01 am
Location: uruguay

Postby pranav81 on Sun Jun 26, 2005 3:21 pm

Just dont install any drivers that came with the motherboard.Use the default Microsoft drivers.I have had too many problems when I installed the drivers that came with the m/b.
Also if you have any problems,just delete the channel on which the problematic drive is,Windows reinstalls the channel and the drive works in DMA mode.

Increasingly mathematics will demand the courage to face its implications.
User avatar
CD-RW Player
Posts: 1160
Joined: Thu Dec 05, 2002 6:57 am
Location: Solapur,Maharashtra,India

Postby dstonek on Sun Jun 26, 2005 3:49 pm

Part of my Nero log file after last burn is:
Recorder: <LITE-ON DVDRW SOHW-812S> Version: US0Q - HA 1 TA 0 -
Adapter driver: <IdeChnDr> HA 1
Drive buffer : 2048kB
Bus Type : default (0) -> ATAPI, detected: ATAPI
CD-ROM: <LITE-ON DVDRW SOHW-812S >Version: US0Q - HA 1 TA 0 -
Adapter driver: <IdeChnDr> HA 1

=== Scsi-Device-Map ===
DiskPeripheral : WDC WD600BB-00DKA0 atapi Port 0 ID 0 DMA: Off
DiskPeripheral : SAMSUNG SV6004H atapi Port 0 ID 1 DMA: Off
CdRomPeripheral : LITE-ON DVDRW SOHW-812S IdeChnDr Port 1 ID 0 DMA: On
DiskPeripheral : Maxtor 92049U3 IdeChnDr Port 1 ID 1 DMA: Off
DiskPeripheral : eUSB Compact Flash EUSBMSD Port 2 ID 0 DMA: Off
DiskPeripheral : eUSB SmartMedia EUSBMSD Port 2 ID 0 DMA: Off

=== CDRom-Device-Map ===
Complete file is here
After the last SP2 reinstall I did not install any drivers, just like the first time.
Windows has installed Microsoft drivers and even so there's no information about DMA. Nero detects it.
The problem is still there.
Buffer Underrun
Posts: 5
Joined: Sat Jun 25, 2005 11:01 am
Location: uruguay

Postby Ian on Sun Jun 26, 2005 5:26 pm

Enable DMA for your hard drives too. If you have further questions, I recommend posting in the "DVD Recordable" section of the forums.. not in the FAQ's.
"Blu-ray is just a bag of hurt." - Steve Jobs
User avatar
Grand Poobah
Posts: 14814
Joined: Sun Apr 08, 2001 2:34 pm
Location: Madison, WI

Postby dstonek on Mon Jun 27, 2005 4:51 pm

I don't know how to set them ON. I only see 'Adv Conf' for primary channel and 'DMA if available' but set to PIO. Secondary channel has not 'Adv. Conf.' tab. It has been lost after un/reinstalling this channel.

Sisoft Sandra is telling me that Current Active Mode is:
Ch 0 device 0 (HD) -> UDMA-5
Ch 0 device 1 (HD) -> UDMA-5
Ch 1 device 1 (HD) -> UDMA-4

Today I have installed XP SP1 in another disk (ch 1 dev1) and on 'Adv. Conf' HD DMA's are set same as Sandra at SP2, plus
Ch 1 device 0 (DVD) -> UDMA-2
I could burn a DVD without problem on SP1 a I used to.
Conclusion: SP2 misunderstands itself. It informs the user the drives are in PIO mode(who knows real transfer mode), it is unable to change or keep SP1 settings in any 'regular' way.
Even worst, as I've been reading I'm afraid it will be a nightmare to uninstall SP2.

Sorry, I came into this forum from another thread that belongs to another forum. How may I move all this posts (after my first one) to another forum?
Buffer Underrun
Posts: 5
Joined: Sat Jun 25, 2005 11:01 am
Location: uruguay

Postby Alektron on Tue Jun 28, 2005 3:12 am

This sounds similar, but not exactly like what I experienced. I have Windows 2000 (SP4) and a Plextor PX-716SA (SATA) DVD burner. I also have 2 SATA hard drives.

I bought my Plextor 16x drive a little over a month ago. At first, I had a limited read and write speed. There were no errors, but I couldn't surpass about 5x or 6x speed!! I was using Nvidia's motherboard drivers. What I did to fix it was remove Nvidia's IDE driver, and re-install only the Windows driver. I kept all the other Nvidia drivers for networking, video, etc. Then I re-booted... it still didn't work!

However, I found that I had to make an adjustment to Device Manager. I changed from PIO to DMA, and re-booted. Then it worked!

Two possibilities for this adjustment, I've seen it both ways.

1.) Go into each IDE controller configuration and check Advanced tab.
Do you see TRANSFER MODE: PIO Only ??! Change it to "DMA if available" for all the IDE configurations and re-boot.


2.) None of the IDE configurations say "PIO Only"!! It says DMA if available. But under that, CURRENT TRANSFER MODE: PIO ??
This is bad. It means your drive is still not running DMA. You need to remove/uninstall that IDE controller. When you finish checking all the controllers for this PIO crap, you re-boot.

The drive should run with full speed!
Whenever I update the firmware of my Plextor, I have to do #2.
User avatar
CD-RW Player
Posts: 134
Joined: Thu May 19, 2005 6:27 pm
Location: USA

Postby dstonek on Sat Jul 02, 2005 7:32 pm

I did a clean SP2 install on my third disk and it recognizes DMA ultra modes for all devices as it used in SP1.
So, my next question are: how may I correct this issue without having to make a clean install on my main installation?
If it would not possible (my God!) how may I backup-restore all (I mean, ALL) settings and data?
Buffer Underrun
Posts: 5
Joined: Sat Jun 25, 2005 11:01 am
Location: uruguay

Return to DVD Writers

Who is online

Users browsing this forum: Exabot [Bot] and 0 guests

All Content is Copyright (c) 2001-2016 CDRLabs Inc.