Home News Reviews Forums Shop

SATA Optical Drives, nVidia Pro Chipset, and XP64


SATA Optical Drives, nVidia Pro Chipset, and XP64

Postby 3rdChaz on Wed Apr 02, 2008 12:50 pm

Here's the setup:

Tyan S2915, and S2915-E mobo's
Areca ARC-1130ML Raid Controller
- 6 Samsung 501LJ Spinpoint Drives
nVidia 8800GT based video
2x AMD 2214 HE
12GB DDR2 667
1 HP1070D
1 Samsung SH183L
1 Antec 550watt EPS power supply for motherboard and optical drives and floppy
1 Acer 350watt ATX power supply for hard drives and fans

Right now the system is configured to dual boot XP 32 bit and XP 64bit. The system boots from volumes on the ARC-1130. The 3 onboard SATA channels have been enabled, but not the nVidia Raid funtionality.

Sata Optical drives are attached to the onboard SATA controller. Under XP64, the drives are recognized but unable to read a disc.

If the drives are attached to a SATA to USB dongle, the sytem will recognize the drives and IS able to read both CD's and DVDs.

So far, I've tried the upper/lower filter registry trick; disabling all unnecessary resources, including the onboard ide controller, deleting all ancilliary apps (like quicktime, itunes, Nero, etc)

Under XP32, I am able read from the drives on the SATA ports.

Any ideas!??? Thanks!
Buffer Underrun
Posts: 3
Joined: Wed Apr 02, 2008 12:07 pm

Postby Ian on Wed Apr 02, 2008 12:58 pm

I haven't tried running XP 64 on an nVidia system yet. Have you tried updating the drivers for the SATA controllers and/or system chipset?
"Blu-ray is just a bag of hurt." - Steve Jobs
User avatar
Grand Poobah
Posts: 14814
Joined: Sun Apr 08, 2001 2:34 pm
Location: Madison, WI

Postby 3rdChaz on Wed Apr 02, 2008 2:09 pm

Thanks for the input. . . yes, I reinstalled the chipset drivers. BTW, no problem with an IDE DVD RW drive. Would prefer to go SATA to minimize cable clutter and maximize airflow in the case. . ..
Buffer Underrun
Posts: 3
Joined: Wed Apr 02, 2008 12:07 pm

I Seem to Have Stumbled Upon a Workaround . . .

Postby 3rdChaz on Wed Apr 02, 2008 11:21 pm

The more I rebooted my machine, and Googled this problem, the more convinced I became it was an x64 driver/I.O. problem. I can't recall precisely who or what inspired me to do so, but even though there were no hard drives installed on the motherboard SATA ports, I enabled the nVidia RAID BIOS via the System BIOS and then enabled the SATA channels under RAID. When I rebooted, XP 64 found the new hardware and asked for drivers. I intalled the raid drivers and rebooted again. The HP DVD RW showed up again, except this time when I put a disk in it, it would run, and show me files rather than an empty directory. Most types of disks seem to work (DVD's, Audio, DATA).

Amazed, I rebooted to XP 32. The system again asked for drivers, except this time, I cancelled the install. The HP was still funtioning just fine under XP 32bit. So, I took a chance, rebooted yet again, and this time disabled the RAID controller from BIOS (it's default btw). When the system came up, the DVD continued to function properly under XP 64!

I'd sure like to find the time to do a more detailed diagnostic to find out what the differences are between the installed x64 bit SATA port drivers and the RAID controller version. . . It seems to me that the RAID controller driver package overwrote a component of the base SATA port drivers. . . but what!??

Thanks for looking y'all. . .
Buffer Underrun
Posts: 3
Joined: Wed Apr 02, 2008 12:07 pm

Return to DVD Writers

Who is online

Users browsing this forum: No registered users and 0 guests

All Content is Copyright (c) 2001-2016 CDRLabs Inc.